SSH X forwarding not working

Chris Horn
Fri Mar 7 02:53:00 GMT 2003

At 04:50 PM Thursday 3/6/2003, you wrote:
>Hmm looked through the mail again and saw:
>|> > ssh -x remote-host
>Have you tried "ssh -X", capital X, using small x disables ssh

Sorry, sloppy typing.  I've been using -X, the text in this email was a typo.

>/ Chris Horn <> wrote:
>| At the other end, /etc/ssh/sshd_config now has the line "X11Forwarding yes"
>| Still no go.
>| When I connect, the DISPLAY value on the remote box appears null.
>| When I'm local, it's "localhost:0.0"
>And this local, it is from the prompt you do ssh from?

Yeah.  When I'm in Cygwin XFree86 on my local machine in an xterm, I've 
been typing 'echo $DISPLAY' to see what it's set to.

>| When I used xhost and set DISPLAY manually, things work:
>just a note, you are aware that the X traffic goes unencrypted when
>doing it this way (setting DISPLAY to host_done_ssh_from)?

Yes.  Which is why I want to get SSH's X forwarding working already!

>| 2. on remote box set DISPLAY to "local_host:0.0"
>Assuming local_host here is host_done_ssh_from?

Yeah.  I was on the remote machine (through a SSH session) and set DISPLAY 
to be the display of the machine I'm sitting at - which I've been calling 
local (because it's right in front of me).

Sorry, I guess I could've been clearer.

>| Also, does anyone know how to cut and paste:
>|          1. Within X (do I have to run XWin with -emulate3buttons?), and
>If you have a threebutton mouse like microsoft with scrollball, you
>probably can use the third button.. (like me)

Huh.  I think the problem is that I have the middle mouse button (the 
scrollwheel) set to double-click in Windows and that behavior is overriding 
what it would normally do in X - namely paste!

I exclusively run Linux on my personal machine at home, so not having paste 
is *really* frustrating!

>|          2. between X and Windows?
>There are work being done on this, check the mailinglist. xwinclip is
>the keyword I think.

I'll check it out; thanks.

703.413.1100 x5100

More information about the Cygwin-xfree mailing list