SSH X forwarding not working

Andrew Markebo
Thu Mar 6 22:01:00 GMT 2003

Hmm looked through the mail again and saw:

|> > ssh -x remote-host

Have you tried "ssh -X", capital X, using small x disables ssh


/ Chris Horn <> wrote:
| At the other end, /etc/ssh/sshd_config now has the line "X11Forwarding yes"
| Still no go.
| When I connect, the DISPLAY value on the remote box appears null.
| When I'm local, it's "localhost:0.0"

And this local, it is from the prompt you do ssh from? 

| When I used xhost and set DISPLAY manually, things work:

just a note, you are aware that the X traffic goes unencrypted when
doing it this way (setting DISPLAY to host_done_ssh_from)? 

| 2. on remote box set DISPLAY to "local_host:0.0"

Assuming local_host here is host_done_ssh_from?

| Also, does anyone know how to cut and paste:
|          1. Within X (do I have to run XWin with -emulate3buttons?), and

If you have a threebutton mouse like microsoft with scrollball, you
probably can use the third button.. (like me)

|          2. between X and Windows?

There are work being done on this, check the mailinglist. xwinclip is
the keyword I think.


 The eye of the beholder rests on the beauty!

More information about the Cygwin-xfree mailing list