xinit: No such file or directory

Shing-Fat Fred Ma
Sun Jun 29 01:10:00 GMT 2003

Andrew Markebo wrote:
> |    + rm -rf /tmp/.X11-unix
> |    rm: cannot remove directory `/tmp/.X11-unix':
> |       Permission denied
> [...]
> |    drwxr-xr-x 2 Name None 0 Jan 29 04:57 /tmp/.X11-unix
> |    srwxr-xr-x 1 Name None 0 Jun 27 16:11 /tmp/.X11-unix/X0
> Yeah, think it is around here the error is, my .X11-unix, it is owned
> by me, assuming Name is your name? 

Actually, that was my mistake.  Name is the userid on the
machine that doesn't have problems.  On the PC that only
lets administrator do startx, /tmp/.X11-unix is owned by
administrator, and does not have write permission for
anyone else.  

> Have you tried removed the file and subdir as admin, and then tried
> firing it up again, BTW My files has the rights 
> drwxrwxrwt+   2 flognat  None            0 May 16 23:37 .X11-unix
> [...]
>               /Andy

Yes, if I remove /tmp/.X11-unix, it gets recreated by
the userid which does startx.  It is writable by
everyone, as is yours above.  For that reason, any
other user can also do startx.  That seems to solve the

So the problem is that the permissions got changed
somehow.  I'm pretty sure it happened when I setup sshd
according to  This
procedure, contains the step "chmod -R go-w /", which
narrows the accessibility of /tmp/.X11-unix to the only
creator.  I guess that it is an attempt to improve
security, given that sshd allows an external login.
However, the subsequent fixup "chmod go+w /tmp" is not
enough to open up accessibility to /tmp/.X11-unix.  

Another part of the problem is that /tmp/.X11-unix is
left behind after X windows shuts down.  This ensures
that the next user to do startx is using the directory
/tmp/.X11-unix created by someone else.  Thus, everyone
is dependent on the directory having write permission
by group and world.  The problem could be avoided by
having the X windows startup scripts/programs remove
/tmp/.X11-unix when X windows shuts down.

Thanks, Andrew, for your help in solving this problem.

Fred Ma,
Carleton University, Dept. of Electronics
1125 Colonel By Drive, Ottawa, Ontario
Canada, K1S 5B6

More information about the Cygwin-xfree mailing list