X server acting funny when displaying remote KDE session

Alexander Gottwald Alexander.Gottwald@s1999.tu-chemnitz.de
Mon Jun 16 16:57:00 GMT 2003

Alexander Gottwald wrote:

> Stefan Heinzmann wrote:
> > Did that, and now the log file says:
> > (**) Using keyboard "Keyboard1" as primary keyboard
> > (**) Option "XkbLayout" "us_intl"
> > (**) XKB: layout: "us_intl"
> > Rules = "xfree86" Model = "pc101" Layout = "us_intl" Variant
> > = "(null)" Options = "(null)"
> >
> > It didn't help, though. Still no dead keys. Maybe I need to
> > set the variant somehow? How would I do that?
> I hoped it would help. I tried to set the map with "setxkbmap us_intl"
> but had no luck too. It seems that the xserver (or xkbcomp) can not read
> the map :(
> I'll try to investigate this.

I've just tested it with my local installation and it worked.
I've used these settings for the keyboard section

    Option "XkbRules"   "xfree86"
    Option "XkbModel"   "pc101"
    Option "XkbLayout"  "us_intl"

If this does not work, you can try
xkbcomp -xkm -m us_intl /etc/X11/xkb/keymap/xfree86 :0

Maybe the output does shed a little light on this problem. There will be
a lot of "Warning:          No symbols defined for <I62> (keycode 226)".
These are quite normal.

NP: Terminal Choice - Beg for Absolution
 http://www.gotti.org           ICQ: 126018723

More information about the Cygwin-xfree mailing list