Can't open display w/Cygwin on Win XP

Harold L Hunt II
Mon Jan 20 02:58:00 GMT 2003


So, the wording of your question suggests that what you really meant to say
was, ``I have a firewall/VNC product installed, but I don't think that is
the problem.''  Is that the case or not?

If you do have firewall/VNC software installed, I can assure you that it
most likely IS the problem; the fact that other software works fine has no
bearing on whether or not Cygwin/XFree86 will work fine.  You see,
Cygwin/XFree86 is heavily dependent upon TCP/IP working exactly correctly.
Remember, we are not just using the Win32 API for TCP/IP... we are using
Cygwin to emulate the POSIX/UNIX interface to TCP/IP using the Win32 API
TCP/IP calls.  This requires taking advantage of some peculiarities of the
Win32 API TCP/IP interface.  Can you assure us that your firewall/VNC vendor
implemented each and every one of those peculiarities correctly?  If not,
then we just have to assume that the firewall/VNC software is the problem.
We have dealt with this issue several times in the past and the correlation
between Cygwin/XFree86 not working and firewall/VNC software being the blame
is about 100% in cases where firewall/VNC software was ever installed on the

Yeah, that's another little bit about the firewall/VNC software: some of the
vendors are sloppy and their uninstall routines do not replace the original
Win32 API TCP/IP DLLs... they just leave their own in place.  We have had
people that have uninstalled firewall/VNC software and still could not get
Cygwin/XFree86 to work.  Then they reinstalled Windows and Cygwin/XFree86
worked.  As a final test they reinstalled the firewall/VNC software and
Cygwin/XFree86 broke.  They uninstalled the firewall/VNC software and
Cygwin/XFree86 was still broken.

That was all in the mailing list archives, but I felt like writing about it
for some reason.

Hope that helps,


P.S. Oh yeah, and if you have never installed firewall/VNC software on your
Windows machine, then kindly disregard the above.  :)

-----Original Message-----
[]On Behalf Of Robert Gottesman
Sent: Sunday, January 19, 2003 12:58 PM
Subject: Can't open display w/Cygwin on Win XP

Starting Cygwin/Xfree86 (4.2) with starxwin.bat or
or startx ends up with the same message them .. Can't open display.

Message from

>sh /usr/X11R6/bin/
Agent pid 2212
xsetroot:  unable to open display ''
>Sun Jan 19 09:42 AM [~]
>twm:  unable to open display ""
xterm Xt error: Can't open display:

I'm running Win XP w/cygwin 1.3.18-1

The FAQ refers to a potential firewall problem ..
which (i believe) is not the case ..
as I run many many other TCP/IP apps on this PC with no problem.

I am at a lost where to start .. as I believe this may have to do
with XP (not seeing any other probable solutions in the archives).

attached is my cygcheck file

-Bob Gottesman

More information about the Cygwin-xfree mailing list