"no buffer space available" on Win2K

Harold L Hunt II huntharo@msu.edu
Wed Apr 30 16:05:00 GMT 2003


I should think that the Microsoft VPN software would not cause problems. 
  My reasoning here is that they don't have to replace the standard 
network DLLs to provide the VPN functionality.  The main problem 
Cygwin/XFree86 has with other VPN software is that just a few operations 
give slightly different results with the VPN software's stack than with 
the standard stack.  As you know, Cygwin is an interesting bit of glue 
that depends on the Windows interface being relatively well known so 
that it can provide a UNIX-like API on top of it.  Any weirdness in that 
Windows interface makes it almost impossible to implement something like 


Jean-Claude Gervais wrote:
> Harold,
> 	Does "VPN software causes problems with Cygwin" apply to the VPN software
> that COMES with Windows?
> 	For example, if someone is running W2K server and is using it as a VPN
> server, will Cygwin still work correctly if the server receives calls from
> W2K client machines using the Microsoft built-in VPN client?
> -----Original Message-----
> From: cygwin-xfree-owner@cygwin.com [mailto:cygwin-xfree-owner@cygwin.com]On
> Behalf Of Harold L Hunt II
> Sent: Wednesday, April 30, 2003 11:31 AM
> To: cygwin-xfree@cygwin.com
> Subject: Re: "no buffer space available" on Win2K
> Karl,
> It is well-known that various VPN software causes problems with
> Cygwin/XFree86.  The reasons for this are numerous, but it primarily has
> to do with the fact that these VPN packages replace various Windows
> system DLLs with their own versions that do not correctly duplicate all
> of the functionality of the Windows networking DLLs.  There isn't
> anything we can do to fix this problem, as we certainly cannot write
> code to deal with x number of networking layers for Windows.
> The only real solution here is to never install the VPN software to
> begin with, as most of them leave their modified DLLs in place when you
> uninstall them.
> The problem would have nothing to do with the window manager.
> I consider your problem solved, as there is nothing I can do to help.
> You could ask the Cygwin list (cygwin@cygwin.com) if you have further
> questions, but I would expect it to get toasty in there if you aren't
> offering to help :)
> Harold
> Karl Waclawek wrote:
>>>Finaly someone else who has had this problem, however I have experienced
> it
>>>using just cygwin ssh and just cygwin ncftp as well as once using x with
> ssh
>>>forwarding. So i have only ever reported it on the cygwin list (to no
>>>responce.) I can give cygcheck etc if anyone wants them.
>>I tried to duplicate it from home (over a VPN connection), but
>>could not get it to trigger. Btw, does anyone know about performance
>>problems with XWindows over VPN? It ran so slow it was unusable - data
> speed
>>was about 1KB/sec, whereas my ADSL is capable of much better.
>>VNC was a lot more usable, but should it not be the other way around?
>>Anyway, got it again this morning. The X session just crashed.
>>When I tried to start it again (using startxwin.sh), the shell returned:
>>listen: No buffer space available
>>xsetroot:  unable to open display ''
>>Could it be caused by the window manager? I was using wmaker, not twm.

More information about the Cygwin-xfree mailing list