"no buffer space available" on Win2K

Karl Waclawek karl@waclawek.net
Wed Apr 30 13:59:00 GMT 2003

> Finaly someone else who has had this problem, however I have experienced it
> using just cygwin ssh and just cygwin ncftp as well as once using x with ssh
> forwarding. So i have only ever reported it on the cygwin list (to no
> responce.) I can give cygcheck etc if anyone wants them.

I tried to duplicate it from home (over a VPN connection), but
could not get it to trigger. Btw, does anyone know about performance
problems with XWindows over VPN? It ran so slow it was unusable - data speed
was about 1KB/sec, whereas my ADSL is capable of much better.
VNC was a lot more usable, but should it not be the other way around?

Anyway, got it again this morning. The X session just crashed.
When I tried to start it again (using startxwin.sh), the shell returned:

listen: No buffer space available
xsetroot:  unable to open display ''

Could it be caused by the window manager? I was using wmaker, not twm.


More information about the Cygwin-xfree mailing list