XDMCP broke

Andrew DeFaria ADeFaria@Salira.com
Fri Apr 25 22:41:00 GMT 2003

Harold L Hunt II wrote:

> Andrew DeFaria wrote:
>> Harold L Hunt II wrote:
>>> Andrew,
>>> Sounds like a problem with your kdmrc file.  Try commenting out the 
>>> [Desktop0] section, or creating a backup of the original file and 
>>> removing it from kdmrc. 
>> I tried deleting the [Desktop0] line to no avail. Also, this still 
>> works at my job where I have, again, and XP box and a Linux box 
>> running Mandrake 9.1. In comparing the kdmrc files I see that the 
>> first line is [Desktop0] both at home and at work. Don't understand 
>> why it works at work and complains at home.
> Not just the line... the whole section until the next [section] label. 

Well again the odd thing is that this section appears in my kdmrc file 
at work and it works fine. I first got this stuff working at work 
between my Mandrake Linux 9.1 box and my Windows XP box. Then I 
performed similar configurations at home and again, as I said before, it 
was working fine. Then it broke and now it complains about this 
[Desktop0] section (yet it does not complain about this [Desktop0] 
section at work).

>>> You will then have to restart kdm.  I believe you can do that on 
>>> Mandrake with (as root): 'service xdm restart'   or perhaps  
>>> 'service kdm restart'. 
>> Actually I found that what get's run is mdkkdm and have killed it and 
>> restarted it, again, to no avail.
> That doesn't actually work as you might think.  kdm is started by a 
> script that spawns a new kdm each time a user connects.  You might 
> have now moved your system into a sort of inconsistent state.  I 
> recommend restarting. 

Well I will try restarting however when I started this there was no kdm 
process running other than the mdkkdm, which appears to be Mandrake's 
(mdk) version of kdm. Also, in the past I was able to kill and restart 
mdkkdm and get things working. It would be nice if man mdkkdm worked! :-(

>>> Of course, you can always do 'init 3' followed by an 'init 5' about 
>>> a minute later.  Or, you can reboot. 
>> I've even downloaded my working kdmrc file from work to no avail. I 
>> don't think I tried rebooting yet. Note that the differences between 
>> my home kdmrc and my work kdmrc seems to be minor and trivial - 
>> thinks like users shown on the login screen and who can reboot.
>> The README states:
>> The configuration files in this directory were automatically generated.
>> As the used algorithms are pretty dumb, the configuration may be broken.
>> This configuration consists of the following files:
>> - /usr/share/config/kdm/kdmrc
>> - /usr/share/config/kdm/Xservers
>> - /usr/share/config/kdm/Xaccess
>> - /usr/share/config/kdm/Xwilling
>> - /usr/share/config/kdm/Xresources
>> - /usr/share/config/kdm/Xsetup
>> - /usr/share/config/kdm/Xstartup
>> - /usr/share/config/kdm/Xreset
>> - /usr/share/config/kdm/Xsession
>> - /usr/share/config/kdm/backgroundrc
>> This configuration was derived from the following files:
>> - /usr/share/config/kdm/kdmrc
>> - /etc/X11/xdm/Xservers
>> - /etc/X11/xdm/Xaccess
>> - /etc/X11/xdm/Xresources
>> Have a look at the program <kdebase-sources>/kdm/kfrontend/genkdmconf
>> if you want to generate another configuration.
>> Kinda odd that /usr/share/config/kdm/kdmrc is generated from the same 
>> file! Also I don't have <kdebase-sources> with which to generate 
>> another configuration!
> <kdebase-sources> isn't a program, it is the base of your path to 
> KDE-Base programs.  Thus, it could be 
> /usr/bin/kdm/kfrontend/genkdmconf or 
> /opt/kd3/bin/kdm/kfrontend/genkdmconf. 

I realize that <kdebase-sources> is a path name and not a program. I 
took <kdebase-source> to mean the base of where you put the sources for 
kde. I have not installed the sources for kde! A search for a file named 
genkdmconf yeilds nothing!

BTW service [xdm|kdm|mdkkdm] restart all yeild: Cannot find 
[xdm|kdm|mdkkdm] service.

man service yeilds No manual entry for service

More information about the Cygwin-xfree mailing list