XDMCP broke

Andrew DeFaria ADeFaria@Salira.com
Fri Apr 25 21:54:00 GMT 2003

Harold L Hunt II wrote:

> Andrew,
> Sounds like a problem with your kdmrc file.  Try commenting out the 
> [Desktop0] section, or creating a backup of the original file and 
> removing it from kdmrc. 

I tried deleting the [Desktop0] line to no avail. Also, this still works 
at my job where I have, again, and XP box and a Linux box running 
Mandrake 9.1. In comparing the kdmrc files I see that the first line is 
[Desktop0] both at home and at work. Don't understand why it works at 
work and complains at home.

> You will then have to restart kdm.  I believe you can do that on 
> Mandrake with (as root): 'service xdm restart'   or perhaps  'service 
> kdm restart'. 

Actually I found that what get's run is mdkkdm and have killed it and 
restarted it, again, to no avail.

> Of course, you can always do 'init 3' followed by an 'init 5' about a 
> minute later.  Or, you can reboot. 

I've even downloaded my working kdmrc file from work to no avail. I 
don't think I tried rebooting yet. Note that the differences between my 
home kdmrc and my work kdmrc seems to be minor and trivial - thinks like 
users shown on the login screen and who can reboot.

The README states:

The configuration files in this directory were automatically generated.
As the used algorithms are pretty dumb, the configuration may be broken.
This configuration consists of the following files:
- /usr/share/config/kdm/kdmrc
- /usr/share/config/kdm/Xservers
- /usr/share/config/kdm/Xaccess
- /usr/share/config/kdm/Xwilling
- /usr/share/config/kdm/Xresources
- /usr/share/config/kdm/Xsetup
- /usr/share/config/kdm/Xstartup
- /usr/share/config/kdm/Xreset
- /usr/share/config/kdm/Xsession
- /usr/share/config/kdm/backgroundrc
This configuration was derived from the following files:
- /usr/share/config/kdm/kdmrc
- /etc/X11/xdm/Xservers
- /etc/X11/xdm/Xaccess
- /etc/X11/xdm/Xresources
Have a look at the program <kdebase-sources>/kdm/kfrontend/genkdmconf
if you want to generate another configuration.

Kinda odd that /usr/share/config/kdm/kdmrc is generated from the same 
file! Also I don't have <kdebase-sources> with which to generate another 

More information about the Cygwin-xfree mailing list