Wierd keymappings and missing Meta

Kirsty Hollingworth keh112@york.ac.uk
Mon Jan 28 05:13:00 GMT 2002

I have installed Cygwin/Xfree86 according to the instructions.  As I live
in the UK I got hold of a Xmodmap for the keymappings.  I tried running

%  xmodmap Xmodmap.uk

where Xmodmap.uk is the mapping file from a bash prompt.  I now get rather
wierd behaviour.  In bash windows (and in xterms running telnet to a linux
box) I find that shift-3 sends #CTRL-M so that # is entered to the prompt.
Also my backspace key prints a ~.  CTRL-H still backspaces though.
However in xedit everthing works fine.  Backspace backspaces and shift-3
prints a pound sign.  Any suggestions?  

On a similar note (and possibly related) I can't seem to work out what my
Meta key in Xedit is.  I've tried pressing the ESC key and sending CTRL-],
CTRL-[ and CTRL-@ before the other keypress.  I don't make use of anything
else that needs a Meta key so I haven't tried anything else.  This didn't
work before I got hold of a keymapping file and it doesn't work

Any help would be very much appreciated - I only really use cygwin/xfree
as an X display but it doesn't work locally either.

|  Kirsty Hollingworth      | This space is traditionally  | 
|      <keh112@york.ac.uk>  |    reserved for comments.    |
|                           |   /* <!-- % ; --  // --> */  |

More information about the Cygwin-xfree mailing list