Remote tasks sleeping after 'su'

Harold Hunt
Thu Jan 24 23:30:00 GMT 2002


What you describe sounds logical.  Remember, it is your username, not root,
that has setup the X tunnelling through ssh.  Therefore, it makes sense that
an X client launched by root would not display.

I'm not a great X user, so I could be wrong... but I do think that the above
makes sense.


> -----Original Message-----
> From:
> []On Behalf Of Rob Haines
> Sent: Thursday, January 24, 2002 12:32 PM
> To: Cygwin Xfree86 Maillist
> Subject: Remote tasks sleeping after 'su'
> Hi,
> I've been using Cygwin for a while now but am new to cygwin-xfree. I hope
> this question hasn't been answered before but I did check the archives and
> didn't find anything pertinent.
> I use this system to log into other systems (via ssh -X) and have the
> windows displayed on my cygwin-xfree desktop. If I run something as myself
> then everything is fine. If I log in, then 'su' to root, then run
> something
> the window never appears. If I look at 'top' then the task I just
> started is
> flagged as sleeping. This problem does not occur when using the
> putty/exceed
> combination to log in to my remote machine. I haven't tried
> logging straight
> in as root, because our security policy does not allow it. Is this a
> cygwin-xfree issue, or something else?
> Thanks in advance,
> Rob Haines
> --

More information about the Cygwin-xfree mailing list