XDMCP : Cannot open display - fatal error problem

Rasjid Wilcox rasjidw@bigpond.com
Tue Jan 8 04:44:00 GMT 2002

On Tue, 8 Jan 2002 15:14, richard harvey wrote:
> Hello all,
> I have been running Cygwin with Xfree for a while now, querying the XDMCP
> server at my work's machine without a hitch - eveything worked just fine. I
> recently installed a second network adapter to share my Internet connection
> with my wife's computer and things still worked fine with Cygwin for a
> while, but I *now* get this message:
> "XDMCP fatal error: Session failed Session 13 failed for display
> myhostname.ca:0: Cannot open display."
> I'm almost sure it worked OK for a while after I installed the 2nd NIC, but
> now I get the X gray stippled background and nothing else!

Are you sure it worked once the second network card was configured?

Are you using the --from IP.Address.Of.Nic.You.Want.To.Use flag when starting 

Failing that, have a look at Alexander Gottwald's ls_netdev at 
http://www-usercgi.tu-chemnitz.de/~goal/xfree/ at it may help diagnose the 
problem (assuming that it is something to do with the network card and not 
something else).

> I'm baffled now as to what happened. I searched the mailing archives to no
> avail. Has someone out there found and possibly resolved this type of
> problem?
> Thanks,
> Richard Harvey
> Montreal, Québec

More information about the Cygwin-xfree mailing list