cygwin-xfree: xdmcp: "no valid address"

Mark Plowman
Mon Sep 24 06:12:00 GMT 2001


> Date: Mon, 24 Sep 2001 14:13:57 +0200 (CEST)
> From: Alexander Gottwald <>
> Cc:
> On Mon, 24 Sep 2001, Mark Plowman wrote:
> > Please excuse me for "barging-in", but my searchs of the 'net seem to
> > indicate that you are (very) knowledgable on the above subject.
> Please ask on the mailing list. The topic might be of interest for others
> too. I also send the reply to the list.

OK, My apologies.

I hope the list accepts postings from non-members.  If I subscribe to
*another* list it will take me more time to follow the list than there
are hours in the day! ;-)

> > My searches in the cygwin-xfree mailing list archives have answered a
> > few questions but left a few over:
> > 
> > 1) Have I correctly accertained that cygwin has a problem with xdmcp
> >    depending on the MS Windows version it is running on (Win 95, Win
> >    98, 2000, NT etc)?
> A recent mail revealed, that the "no valid address" error not only 
> occured on Win95 but also on WinNT. I also had this error on Win98.
> On the other hand, for all Win95, Win98, WinME, WinNT and Win2k we
> had success report, so I would say this error does not depend on a
> special windows version. 

It is getting wierder and wierder.

Last week I configured a colleague's Windows 2000 box and it worked
like a dream, first-time, straight out of the box.

At the weekend I tried to get my Wife's Win-95 box to work and
encountered the problem.

> > 2) Is it now clear (with the currecnt cygwin-xfree version) which MS
> >    Windows it *will* work with xdmcp?
> All versions will work (I know nothing about WinXP, but it's not supported
> by cygwin). But you might get an error. This error might be caused by
> multiple network adapters (2 Ethernet cards or 1 Ethernet and one IRDA 
> interface or modem)

The Windows 2000 has only 1 network interface and "route print"
mentions therefore 2 interfaces, the Ethernet interface and the
loopback interface.

My Wife's Win 95 box also only has 1 network interface, but is not
accessable here so I can't do the same "route print" to see what the
system thinks.  I will try tonight.

Any further thoughts welcome...

> bye
> 	ago



More information about the Cygwin-xfree mailing list