Trying to get enlightenment compiled

Jon Volden
Tue Sep 4 13:54:00 GMT 2001

> > I did that. Installed as service.
> > Recompiled X with CygIPC in my host.def file.
> > Got the ./configure line that says -lipc to say yes now.
> > <Side note: isn't it libcygipc.a?>
> > 
> > Basicly I've done everything that Alan said in that post. 
> > Just wondering if anyone else has had luck with enlightenment 
> > recently 
> > and if they have if they had to modify e in any way.
> > 
> > >Visit and look for Related Sofwtare link and find 
> > >CygIPC from CygUtils site. You need to link to libipc.a
> > 
> > What do you mean link? Something other than what 'make' 'make 
> > install' in cygipc does?
> link means link
> you should link your executable to -lcygipc  Edit Makefile and where it says
> -lipc reaplace it with -lcygipc

Did that also. Was actually the first thing I tried after installing cygipc.
Although I went back and changed it back to -lipc afterwards and seemed to
get the same result. =\ 

If you have any other ideas I'd love to hear them. I am currently starting over
on another box to see if I fat-fingered something, or messed something up in
my efforts. X is almost done compiling. :)

I still think it might be something in the enlightenment code, because the shmtool
compiles just fine using shmget functions. I am no programer so I am lost when
I look at the code. Should I be able to compile shmtool without libcygipc.a?

> > >Suhaib

Do You Yahoo!?
Get your free address at

More information about the Cygwin-xfree mailing list