Your XDMCP patch for Win 95

Tue Dec 4 07:02:00 GMT 2001

I'm getting the error: "XDMCP Fatal error: Session declined with no
valid address".  I can start an X session locally on the Win 95 box,
telnet to the LInux box and run X programs remotely that way.  However,
If I use "XWin -query -from" I get the error.
I've read all the previous posts about XDMCP problems but none of the
suggestions worked.  I do have the Win95 machine name in the /etc/hosts
file and in the Xaccess file on the Linux box.

My other machines (Netpliance I-Openers) can connect fine using xdm.
They mount their entire filesystem over NFS and I assumed they are using
XDMCP to get the logon screen.  Maybe something is still messed up with
my XDMCP configuration?  Thanks for your help.


You wrote:

You don't need this patch anymore. It is in cygwin since 1.3.4.
I'll throw a comment to the page.

Did you have problems with xdmcp and the unpatched 1.3.6 cygwin?
What was it?

> Hi,
> I am having trouble getting XDMCP to work with Windows 95 and a RedHat

> 7.1 Linux box.  I have other X-terminals working fine but the Cygwin
> doesn't work.  I downloaded your patch (cygwin1.fixed-netdev.dll.bz2)
> but it appears to be for Cygwin version 1.3.3 while the current
> I have is 1.3.6-1.  I tried to downgrade my version but I couldn't
> the old files anywhere.  If I use your patched DLL, I get an error
> missing exports in the DLL.

More information about the Cygwin-xfree mailing list