Arrow keys, etc

Suhaib Siddiqi
Mon Oct 2 07:07:00 GMT 2000

> I have installed Xfree on an NT box. Everything seems to work
> but I have the following problems:
> 1. vim works properly only in xterm. In rxvt the arrow keys don't move
> the cursor.

rxvt is not part of xfree86, therefore it is not officially supported.
I am sorry for it.  You need to check with rxvt Home Page, on how to

> 2. I downloaded nedit since xedit doesn't work. Again nedit works but
> arrow keys don't work.

What is the problem with xedit? Could you please send a detail error
messages, please?
nedit, has some issues, but mailing list posted some work around
on their mail lists.

> I can only move the cursor with the mouse. This is a problem with Xwin
> since I tried with a commercial
> server and nedit works fine.

You need a good /etc/termcap file.  I think that is the cause of your

> 3. The supplied xedit does not works. It displays a message: error:
> shell widget has filemenu with zero
> width or zero height and dies.

I will check into it.

> 4. I tried to change the background color with e.g. 'xsetroot -solid
> blue' but I get a red color instead.
> Any help about how to fix these problems?

This could be because at present only 256 colors are supported?


> TIA, Yadin.
> ---
> +----------------------------------+------------------------------+
> |Yadin Y. Goldschmidt              |                              |
> |Professor of Physics              |       voice:  (412)624-9024  |
> |Dept. of Physics and Astronomy    |         fax:  (412)624-9163  |
> |University of Pittsburgh          |      e-mail:                 |
> |Pittsburgh PA 15260               |     |
> +----------------------------------+------------------------------+

More information about the Cygwin-xfree mailing list