Error running freeciv on dxwin32

Carl D. Blake
Fri Jun 9 10:05:00 GMT 2000

Its pretty slow.  I haven't had much of a chance to really exercise it.  I
have a linux system that I used to run X programs on it with my Win95 system
as the X server and it worked, but pretty slowly.  I couldn't tell if that
was a result of network lag or terrible performance on the part of the X

Regarding the font problem, dxwin32 seemed to be able to see the fonts that
it needed in the original tar package.  I'm pretty sure the fonts are in the
right place.  I just tried an experiment where I took xfree86-fonts.tar and
installed that, then moved all the fonts to /usr/lib/X11/fonts, decompressed
them and changed the fonts.dir files to point to uncompressed files.  It
seemed that there were more fonts in this package and I thought that maybe
the missing fonts would be there, but it didn't work.  It had the same
behavior.  I don't know if there's something missing associated with gdk or
what's happening.

I don't have a full cygwin installation so I'm not using any of the mount
points associated with cygwin.  Again the X server seems to work fine with a
lot of X programs (especially those running on my linux system).

----- Original Message -----
From: Nick Thompson <>
To: Carl D. Blake <>
Sent: Friday, June 09, 2000 9:36 AM
Subject: Re: Error running freeciv on dxwin32

> Dxwin32 is a windows program as I'm sure your aware. In my default setup
> cygwins /usr/lib is a mount point for c:\lib. So when I unpacked the fonts
> using cygwin, the fonts ended up in c:\lib\... However in windows, there
> another, separate, directory; c:\usr\lib. It is this directory where
> goes looking for the fonts.
> To work around this, I bunzip2'd the files in cygwin, leaving me with
tars. I
> then used winzip to unpack the tars to c:\. Now windows and dxwin32 can
see the
> fonts. Cygwin can't, unless I also unpack into /usr/lib under cygwin. What
> mess!!!
> Well, that was my problem; it may not be yours. My font files ARE
> What performance do you get out of dxwin32? Mine is lousy :(
> Nick.
> "Carl D. Blake" wrote:
> > I am having problems running freeciv using the dxwin32 X server.  The
> > starts up fine.  Everything seems to be running.  I then run the freeciv
> > client and get the following messages:
> >
> > Gdk-CRITICAL **: file gdkfont.c: line 205 (gdk_font_ref): assertion
> > !=NULL' failed.
> >
> > Gdk-CRITICAL **: file gdkfont.c: line 205 (gdk_font_ref): assertion
> > !=NULL' failed.
> > 1: Could not open file "/g/Program files/Freeciv/./.civclientrc"
> > Gdk-ERROR **: X connection to :0.0 broken (explicit kill or server
> > shutdown).
> >
> > The X server is still running - it has not been killed or shutdown.  The
> > freeciv client stops at this point.  I have attempted to install all of
> > fonts in xfree86-fonts.tar, but the X server doesn't seem to see them.
> > impression is that the dxwin32 will not work with compressed fonts (is
> > true?).  If I need to install more fonts, how do I go about doing that?
> > I've been playing around with the fonts.alias and fonts.dir files and
> > decompressing various fonts, but I'm having no luck.

More information about the Cygwin-xfree mailing list