XWin Direct Draw error

Nick Thompson nickthompson@lucent.com
Fri Jun 9 06:44:00 GMT 2000

Suhaib Siddiqi wrote:

> >
> > The DirectX home page says 7.0a, that I have, is the latest. Is
> > there a 7.1
> > somewhere?
> >
> Sorry NO.  I guess I am still sleeping.  MSDN site has only DirectX 7.0 SDK
> Did you try executing some of the sample DirectX and DirectInsput
> executables which comes with DiirectX.  I do not have access to Windows95.

I downloaded the DirectX update. What executables could I try? If there was a
DirectX problem, surely the DXWin32 server would also fail, but it works; just
very slowly.

> Doing a search in MSDN Subscription site.  I found the following article.
> The cause of the problem could be misconfigured monitor, incompatible
> video driver, i.e. a video driver which cannot handle direct draw Create
> Surfce.
> Read the following from MSDN.  I am cuting nad pasting here:

Thanks. I tried those things. I still have the Plug and Play monitor set up.
Still no go...

> >
> > >  BTW: is there a 233 MHz PIII?  or do you mean Pentium only?
> >
> > You're right its just a pentium
> I will check speed problem.  Is the X-servers take too long to start
> or opening remote Display is slow?

It starts up okay. The first (local) xterm appears quickly. The first slowness
I see is when that xterm tries to scroll - a long 'ls' for example. Remote
windows also take a long time to update, locking up the whole X server while I

BTW: the reason I could not see /usr/bin/X11 and /usr/lib/X11 in both windows
and cygwin, was because c:\bin is mounted as /usr/bin and c:\lib as /usr/lib,
but the is also a real c:\usr\bin & lib. So I have to unpack the windows
servers in windows. My cygwin install is standard (I changed nothing). Why is
this confusing setup used I wonder? I understand why the mounts are present,
but why have a c:\usr\bin with another copy of everything thats in c:\bin???


More information about the Cygwin-xfree mailing list