Getting New XServers to Work

Suhaib Siddiqi
Thu Jun 8 11:50:00 GMT 2000

> >
> NT-4.0 SP5.  AFAIK this includes DirectX3.  When I run
> startxwin.bat I get a
> pop-up saying

You may have to upgrade to SP6a.  Upto SP5 DirectInput was
almost not supported,
thought is still very lousey on SP6a.  You may have a little bit
better luck with SP6a.

> Acquire Keyboard
> and the XWin exe returns:
> scheduling timer: Invalid argument
> _XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root
> pwin->width = 00000500
> pwint->height = 00000400
> pwin->paddedWidth = 00000a00
> pwin->bitsPerPixel = 00000010
> calling winAllocateFramebufferMemory
> calling cfb16ScreenInit( 0a04fca0, 0sd50000, 0000500, 00000400, 00000064,
> 00000064, 00000500 )
> Successful addition of Screen 0xa041df4 0xa04fca0
> error opening security policy file
> /usr/X11R6/lib/X11/xerver/SecurityPolicy
> After that it dumps core.

That is because DirectX/DirectInput is the problem and it is causing server
to crash.

> When I try DXWin32 or XGDI with the -fp option, I still get the messages
> about rgb and default font, but in between I get a message saying:
> failed to set default font path 'D:\cygwin\usr\lib\X11\fonts'

DXWin32 and XGDI, MUST be installed in \usr\bin\X11 and fonts and libs in
and \usr\lib\X11 etc.  These are MSVC compiled executables and do not
understand Cygwin mount points.  For DXWin32 and XGDI D:\cygwin\usr

is D:\cygwin\usr not D:\usr.  It needs everything to go in d:\usr.


More information about the Cygwin-xfree mailing list