cannot load xf_dx.dll!?!

Suhaib Siddiqi
Thu Jun 8 10:13:00 GMT 2000

> I followed the thread on this one, but even though I installed the full
> 'X servers 1.0 tar.gz',

I do not understand.  What has xf_dx.dll to do with X-servers v 1.0?

X-servers v 1.0 uses no xf_dx.dll.  It uses DirectX installed on your
Windows.  You must have DirectX, at least version 3.0, installed on your
Windows OS.

Only xwin.exe (x-server executable) in xfree86-4.0-xwin.tar.bz2 uses
xf_dx.dll and it also need the DirectX and DirectInput installed
on your Windows.

X-servers v 1.0 uses C:/usr/bin/X11 and c:/usr/lib directory structure (you
can have
any drive letter, C: is not a must). See previous
message I posted to list.  The startdx.bat and startx.bat files looks for
"usr" directory at toplevel of the same drive.  If you have install it on
c;\ drive it should find c:\usr\bin and c:\usr\lib, plus everything beneath

xwin.exe from xfree86-4.0-xwin.tar.bz2 needs the following directory

and /usr/X11R6/lib

xwin.exe is a Cygwin application.  The X-servers from X-servers-v-1.0 are
applications, except xterm and twm and needs a cygwin1.dll in path.


>and copied the /usr/bin/X11 files to
> /usr/X11R6/bin, and deleted the cygwin1.dll (caused access violations),
> I still get the message that the xf_dx.dll can't be loaded. This is the
> same error that has been reported already, but I haven't seen a fix
> (that works for me) yet.
> The dll is present (/usr/X11R6/bin) and /bin, /usr/bin and
> /usr/X11R6/bin are all in my path.
> Any more ideas? (Win95, cygwin1.1.2)
> Nick.

More information about the Cygwin-xfree mailing list