Installation problems

Suhaib Siddiqi
Wed Jun 7 05:36:00 GMT 2000

> I tried to install the X-Server binaries 1.0  from the contrib dir on a
> fresh installed cygwin-net-environment.
> The first problem was the the cygwin setup mounted the lib to /usr/lib.
> So the fonts, rbg.txt haven't been in the right place. Maybe the cygwin-
> developer will correct this problem.
> My Solution was to unmount the lib dir and then install the Xservers.
> Now the XServer can be started successful. But when i tried to start xterm
> I get the following problems:

The other work around is:

Install it in /usr directory and use DOS shell to start X-server. It works
fine for X-servers-v-1.0

> bash-2.04$ xterm
> y:\usr\bin\X11\xterm.exe: *** shared region is corrupted.  inited 14
>       0 [main] ? 0 lpfu: void pinfo::record_death (int):374 having
> problems gett
> ing lock
>    2109 [main] ? 0 lpfu: *** void pinfo::record_death (int)(374), pid 285
> unloc
> ked, rc -1, Win32 error 6
>    6851 [main] ? 0 unlock_pinfo: ReleaseMutext (pinfo_mutex<0x0>) failed,
> Win32
> error 6

This is due to conflicting versions of Cygwin1.dll.

You should use startx.bat or startdx.bat supplied with X-server.  They are
in usr/bin/X11 directory.  If you use one of these batch files to
start X server, an xterm should open automatically.  Please check
the announcement message.  I did mention use one of these
batch file. The X-servers itself were compiled using MSVC and do not use
Cygwin1.dll. Xterm and windows managers make use of pttys, therefore
these applications cannot be compiled using MSVC, at the moment, unless
someone contributes a driver or DLL which provides pttys for MSVC.


> Any Idea ?
> Ciao, Dirk
> --
> Sent through GMX FreeMail -

More information about the Cygwin-xfree mailing list