libXm.a + xmkmf

Suhaib Siddiqi
Fri Jun 2 03:46:00 GMT 2000

> -----Original Message-----
> From:
> []On Behalf Of Tom
> Weichmann
> Sent: Friday, June 02, 2000 3:14 AM
> To:
> Subject: libXm.a + xmkmf 
> Hello,
> I am running cygwin 1.1.1 on Win98.  I an using the binary release 
> of the x clients and libs from the cygwin/xfree86 page.  I am trying 
> to compile a x file manager called mfm, and I an getting the 
> following errors when I xmkmf -a :
> makedepend: warning:  pty.c, line 3: cannot find include file "fcntl.h"
>         not in /usr/X11R6.4/include/fcntl.h
>         not in /include/fcntl.h
>         not in /usr/local/lib/gcc-include/fcntl.h
>         not in E:/usr/H-i386-cygwin32/i386-cygwin32/include/fcntl.h
>         not in E:/usr/H-i386-cygwin32/lib/gcc-lib/i586-cygwin32/egcs-
> 2.91.57/inc
> lude/fcntl.h
> This error is repeated over and over for every file in the tar ball.  
> Where does xmkmf get its info from?  None of the include 
> directories which make is looking in exist on my system. 

"None of the include directories..." <---THIS IS YOUR PROBLEM.  
You cannot compile a code if you do not
have proper headers for it, a full compilation suite (compilers).
A proper installation of Cygwin.

xmkmf is getting it from your pty.c subroutines, which needs fcntl.h header


> I copied 
> all of the include file needed into /include (one of the directories 
> which make was searching) and tried again.  This time xmkmf -a 
> worked correctly.
> Next I typed make.  Make died with the following error:
> $ make
> rm -f mfm.exe
> gcc -o mfm.exe -O2 -s -mpentium      -L/usr/X11R6.4/lib accels.o    
>      dd.o d
> vices.o         fileMgr.o         fileSelectionBox.o    ftp.o   
> globalLList.o
>       info.o         menubar.o         mfm.o         pty.o        
>  typesFile.o
>        util.o -lXm -lXt -lSM -lICE -lXpm -lXext -lX11
> /usr/X11R6.4/lib/libXm.a(ResConvert.o)(.text+0x145d):ResConvert.c:
>  undefined re
> erence to `_ctype_'
> /usr/X11R6.4/lib/libXm.a(ResConvert.o)(.text+0x1478):ResConvert.c:
>  undefined re
> erence to `_ctype_'
> /usr/X11R6.4/lib/libXm.a(ResConvert.o)(.text+0x1490):ResConvert.c:
>  undefined re
> erence to `_ctype_'
> /usr/X11R6.4/lib/libXm.a(ResConvert.o)(.text+0x1b20):ResConvert.c:
>  undefined re
> erence to `_ctype_'
> /usr/X11R6.4/lib/libXm.a(ResConvert.o)(.text+0x1b26):ResConvert.c:
>  undefined re
> erence to `_ctype_'
> /usr/X11R6.4/lib/libXm.a(ResConvert.o)(.text+0x1b46):ResConvert.c:
>  more undefin
> d references to `_ctype_' follow
> collect2: ld returned 1 exit status
> make: *** [mfm.exe] Error 1
> This looks to me like libXm.a needs to be re-compiled with the 
> latest cygwin.  So this leads me to my next question.  Do I need to 
> download XC40-1 - XC40-4 from the ftp site just to build the libs and 
> clients, or is that for the xserver as well?  Is there another, smaller 
> source I can use if I just want to build the libs and clients?
> Thank you for your time,
> Tom Weichmann

More information about the Cygwin-xfree mailing list