Xserver crashes

Harald Schäfer schaefer@beta1.wi-inf.uni-essen.de
Tue Jul 25 10:11:00 GMT 2000

"Suhaib Siddiqi" <ssiddiqi@inspirepharm.com> wrote:
> > _XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root
> > pwin->width = 00000500
> > pwin->height = 00000400
> > pwin->paddedWidth = 00000a00
> > pwin->bitsPerPixel = 00000010
> > calling winAllocateFramebufferMemory
> > and an Windows Popup-Window with the following error message:
> > "Direct Draw Init Failed
> >  Error = 80004001 (DIERR_UNSUPPORTED)"

> Did you try startiung using startxwin.bat from a DOS shell or startx from a
> bsash shell?

Yes, I've tried to start the Xserver with the startxwin.bat command from
a bash shell. It caused the same error message.

Yukihiko Sohda <sohda@is.titech.ac.jp> wrote:
> I think these often reported error "Direct Draw Init Failed" depends on
> the display driver.

> First, I tried on ThinkPad600E (Windows2000JP, NeoMagic 256AV),
> I encountered this error. Next, I tried with my Desktop PC (Windows2000JP,
> RivaTNT), I could start the XServer (of course, twm and xterm too!).

> And I got the following NeoMagic DirectX information:
> "NeoMagic provides drivers to notebook computer makers which are
> compatible with DirectX 2 and DirectX 3. "
> Yes, NeoMagic display driver does not certificated by Microsoft.

> Some display drivers don't support the full DirectX7 functions,
> so that XServer crash with the error "DIERR_UNSUPPORTED", I thought.

I think Yukihiko Sohda is right. I'm using an ASUS L7300 notebook with a
Silicon Motion Lynx and the  driver isn't certified by Microsoft, too.
Maybe I'll try to get a newer driver.

  Harald Schaefer

More information about the Cygwin-xfree mailing list