Xfree8686 4.0.1 based new binaries for Windows

Robert Cicconetti zarquon@resnet.gatech.edu
Wed Jul 19 20:54:00 GMT 2000

Well, I downloaded all the new archives in xc-4-binaries (dated 7/19),
removed the older X11R6 directory, expanded them to /.  After adding
/usr/X11R6/bin to my path, I ran startxwin.bat.  Results:  Status Access
Violations, and 4 or 5 popups windows saying "The instruction at 0x24548d00
referenced memory at 0x24548d00.  the memory could not be read." (from
Xwin.exe).  Replacing Xwin with Xvfb in the batch file yields the same

Cygwin 1.1.2 netrelease (very latest, including the updated DLL)
Windows 2000 pro
ATI All-in-Wonder 800x600x16
Dual Celeron 550s

Previous snapshop worked okay; XWin tended to crash, but Xvfb was stable.

Running alternate script stwin:

export DISPLAY=

export PATH=$PATH:/usr/X11R6/bin
echo $PATH
gdb -nw "Xvfb -screen 8 640x480x16 -whitepixel 255 -blackpixel 0"
xterm -sl 1000 -sb -rightbar -ms red -fg yellow -bg black
rxvt -fn "Lucidia Console-12"

(gdb) run
Starting program: /usr/X11R6/bin/Xvfb.exe

Program received signal SIGSEGV, Segmentation fault.
0x61004ac3 in _size_of_stack_reserve__ ()

Xwin crashes in the same spot.  Any ideas?

Robert Cicconetti

More information about the Cygwin-xfree mailing list