Motif and Xt Widgets using Cygwin20/NT

Poor, Jeff
Mon Jul 17 14:34:00 GMT 2000

It appears that I rattled a few nerves by asking the original question of
this thread.  For that I do apologize.  I realize that Cygwin and all the
related software items are "free", and that any support provided is major

Let me please recap my situation, and if there is a solution I would be most
thankful for response:

My only past experience with Cygwin was the B19 version packaged with ModSAF
5.0 (a STRICOM DOD defense simulation).  Folks at STRICOM were capable of
getting ModSAF (a UNIX/X11 application) running under Cygwin, with some help
from Hummingbird (Exceed).

As stated in my original message, I have large scale Alpha/VMS C/X11/Motif
application I would like to attempt to re-host on a PC (Win-NT) without
major changes to the software.  Cygwin seem a feasible method for attempting
this task, so I DID research the web pages and attempted to develop a
working configuration.

Obviously, some of us that aren't intimate with the Cygwin development are
unclear on versioning of the product (doesn't the confusion in the past
email relay this issue?).  I believe there is something called B19, another
called B20 (beta versions, downloadable?) ... and still something else known
as V1.1.2 (is this the distributed CD-ROM product?).

As I stated in my original message, I did tinker some with various "X11"
releases and Cygwin B20 (i.e. I used Cygwin_B20_full.exe
cygwin-xfree-x11r6.4-cygwin-B20.1.tar).  I tried using the Unv of Tennessee
self-install, and then tried running the DroolView update.  I tried using a
the file B20_X11R6_4.tar.gz created by Arlindo da Silva out of NASA/Goddard.

I did read the FAQ's and the mail archives attempting to get past the
version incompatibilities, which eventually lead me to the submitting my
question (i.e. Motif and Xt Widgets using Cygwin20/NT).  

The initial response back from the mail list was: "link to libXm.a and if
you do not have it get it from".   I followed those
directions, which created the "version problems" and created a new "crop" of
questions on my part. Suhaib's response then was: "  You are doing something
basically very wrong, mixing X11R6.4 for B20.1 with Cygwin 1.1.2, ...".

My two questions at this point are:

1) 	How can you state that I'm "X11R6.4 for B20.1 with Cygwin 1.1.2"?  I
thought I was using B20, and really have no idea how you came to the
conclusion I was using "1.1.2".

2) Where specifically is a "installable" version of Cygwin (version 1.1????)
available that will run with the file lesstif-0_90-cygwin-1_1_tar.gz (which
appears to be the resource I need to get the Motif like functions)?  Mirror
sites appear to only have setups for B20 versions.  Is it possible
(plausible) to un-tar the file cygwin-1.1.2.tar.gz into my B20 directory
structure and have it run (vs. doing a Windows-NT Install)?

Again, I apologize for my blatant ignorance one the subject at hand (I did
state up front that wasn't "an expert").  Hopefully this message conveys
that fact that there is confusion in the realm ... perhaps a short tutorial
on the subject would aid all of us.

Thank you again for all the time and effort put forth.

Jeff Poor
Northrop Grumman
Airborne Ground Surveillance and Battle Management Systems 
Melbourne, Florida
(321) 726-7335

	From:  Poor, Jeff
	Sent:  Friday, July 14, 2000 12:40 PM
	To:  ''
	Subject:  Motif and Xt Widgets using Cygwin20/NT

	I'm attempting to port a large GUI application (written in C) that
originally ran on an Alpha/VMS system onto a PC running NT4.0.  By no means
am I a Motif/X11 expert, but I have successfully ported this application to
a SUN/Solaris platform with very little effort.

	I've installed Cygwin with the Cygwin_B20_full.exe, and have used
the cygwin-xfree-x11r6.4-cygwin-B20.1.tar file to get the latest X11 &
Motif.  (Note, I danced around quite a bit getting correct version that
worked, DLLs, etc.)

	At this point, a large number of the Motif Widget classes aren't
being found .... for instance, when I go to link I see things such as:

	  undefined reference to `xmTextWidgetClass'
	  undefined reference to `xmSeparatorWidgetClass'
	  undefined reference to `xmArrowButtonWidgetClass'
	  undefined reference to `xmArrowButtonWidgetClass'
	  undefined reference to `xmSeparatorWidgetClass'
	  undefined reference to `xmTextWidgetClass'
	  undefined reference to `XmTextSetString'

	Each of these classes are defined as "extern" with the *.h (header)
files under /X11R6.4/lesstif/Motif1.2/include (and Motif2.0).

	There are also some totally undefined functions (Xshm, Xmalloc,
Xcalloc, XWidthofScreen, ...) that are present within VMS and Solaris, but
don't appear anywhere in the Xfree bundle.

	Also, in the link phase I get the following messages which are X11
related but not specific to the above mission objects:

undefined reference to `IceConnectionNumber'
undefined reference to `IceProcessMessages'

	Any leads on what these anomalies are caused by?  THANKS!!!!

	Jeff Poor
	Northrop Grumman
	Airborne Ground Surveillance and Battle Management Systems 
	Melbourne, Florida
	(321) 726-7335

More information about the Cygwin-xfree mailing list