Suhaib Siddiqi
Wed Jul 5 04:15:00 GMT 2000

Debug your code.

Make sure X11 DLLs are available to nedit.exe.  That is /usr/X11R6/bin must
be either
in PATH or copies of DLLs must be in the same directory as nedit.exe.

> Hi Suhaib,
> Thanks for the info about Motif, excuse my ignorance.
> I downloaded the binary distribution of lesstif for cygwin1.1.*
> was able to
> compile nedit5.1.1 (also managed to compile the older nedit5.0.2) BUT both
> versions core dump on me with:
> 0 [main] NEDIT 1021 handle_exceptions: Exceptions: STATUS_ACCESS_VIOLATION
> For now I went back to my old nedit5.0.2 that I had compiled with
> cygwinB20.1
> and with your old X11R6.4/MOTIF dist..
> What am I doing wrong here? All I did to build the nedit5.1.1
> executable was to
> add the lesstif path in the makefiles/Makefile.cygwin that came
> with nedit5.1.1.
> I thought that maybe the binary distribution of lesstif caused
> the problems and
> downloaded the sources and recompiled the Xm library, but same problem...
> Oh on other thing I tried was to use the Motif2.0 in stead of
> Motif1.2 libraries
> when I compiled nedit5.1.1. Needless to say without success. (I.e. nedit
> compiles but core dumps as described above.)
> Did you actually compile nedit5.1.1 your self? What am I missing?
> Thanks for your help,
> Gerhard
> P.S. One last thing I tried was to use the makefiles/Makefile
> linux instead of
> the makefiles/Makefile.cygwin file. -> Same result.

More information about the Cygwin-xfree mailing list