Installing cygwin/xfree : it works ! ( almost )

Suhaib Siddiqi
Mon Jul 3 05:17:00 GMT 2000

As I mentioned in my previous mail.  GGI is not
actively supported because John Fortin who did GGI
libraries ports had left the project a couple of
months ago.  The code and binariesa e their for
someone who will be willing to continue work on it or
for users to use it on their own.

BTW:  GGI has libGII which controls the Input.  You
need to find out from GGI mailing list how to change
keyboard input htpp://


--- "Richard.GRENON" <>
> Hello Suhaib and others,
> Installing and using Cygwin was very easy and it
> works very well, but installing Xfree with XGGI is
> really a nightmare for a simple user who knows
> nothing about system administration. I will never
> say bad things about system administrators!
> Here are the last (bad) news of my installation :
> 1. xterm warnings "locale not supported" and "failed
> to open input method" : I tried to get the last
> xterm client from Xc-4-binaries as you told me, but
> it gives the same thing. I read in the archives that
> you said it was not important, so maybe I can forget
> it.
> 2. French keyboard mapping : I got a french
> file on the Web and tried xmodmap or to
> run XGGI with the -xkbdb option. No way! Xterms are
> always typing US keyboards! Help! What is missing to
> make xmodmap work?
> 3. Twm does not catch button events : I tried the
> last twm.exe from the Xc-4-binaries and also mwm,
> but it's the same problem although "xmodmap -pp"
> says that there are 5 buttons! Could it be because
> some env variables are missing (look at my very
> simple XGGI script in my June 26 mail) or because
> the window manager cannot find the *wmrc files ?
> System *wmrc files exist for twm and mwm, but maybe
> at the wrong place? I tried also to run XGGI with
> the "-buttons n" option but it fails for any value
> of n between 1 and 3! Help again!
> 4. Finally I tried to exec a Unix code :
> XopenDisplay works with DISPLAY=localhost:0.0 but
> DISPLAY=:0.0 is not authorized, because I am not
> root ? Then the code fails on
> DefaultColormap(display,screen) call with the screen
> value returned by DefaultScreen(display). This
> screen value seems to be out of range (very great
> value). What is wrong?
>   I had also a problem with the choice of the
> include files : gcc seems to look for the X11
> include files in /usr/include/X11. Some X11 files
> are in /usr/include/X11 (from cygwin installation)
> but they are not identical to the same named files
> in /usr/X11R6/include/X11, so which ones should I
> use?
> As you can see, I am completely lost among the
> include, resource or config files and the init
> scripts. That's really not my domain and I don't
> have the basic knowledge of system administration. I
> think I have all the latest binaries needed for
> simple tests but I will never succeed if I can't
> find a full installation script with XGGI or another
> Xserver. I guess that you could be tired to receive
> always the same questions, and I don't want to take
> too much of your time. Maybe I will do again some
> other tests if you have some suggestions, but I
> think I will stop soon. Do you intend to deliver in
> the future full install scripts for Xfree with some
> Xservers, as you did with the setup.exe for Cygwin ?
> If so, I think that it would be better for me to
> wait.
> Thank you again for having given me a little of your
> time.
> Best regards,
> Richard Grenon
> 40 Avenue de la Division Leclerc
> 92320 Châtillon - France
> e-mail :

Do You Yahoo!?
Kick off your party with Yahoo! Invites.

More information about the Cygwin-xfree mailing list