XGGI implementation

ssulma@docspace.com ssulma@docspace.com
Mon Feb 21 15:21:00 GMT 2000

> Don't you have to make a copy of libgg-0-0-6.dll to libgg-0-0-7.dll
>  and same for libgii?

> It is in FAQ on Cygwin-xfree URL? If I am not mistaken.

I made the copies as noted in the post (libgg and libgii to 0-0-6, still in

> It clearly seems to me that input libs (libgii and libgg) are not getting loaded.

When /usr/local/lib is not in the path, I receive a message that it cannot
load libgg-0-0-6.dll. This is as I expected. When the directory is in the
path, the app loads and the window appears, with no notification that there
is a missing dll -- thus I assume it _is_ being loaded. But still no debug
messages.  (or mouse/keyboard input)

To be sure and to make sure no one was left out I tried this.  With no
additional success:

$export GGI_DEBUG=255
$export GGI_DEFMODE=800x600[GT_16BIT]
$export GGI_CONFDIR=/usr/local/etc/ggi
$export PATH=/usr/local/lib:/usr/local/lib/ggi/display:/usr/local/lib/default:/usr/local/lib/input:/usr/local/lib/filter:/usr/local/bin:/usr/bin:/usr/X11R6/bin:/bin
$XGGI -targets directx
PEXExtensionInit: Couldn't open default PEX font file  Roman_Merror opening security policy file /usr/X11R6/lib/X11/xserver/SecurityPolicy

(the last prompt after I closed the window)

(I don't think I'm missing anything.)

ls /usr/local/lib

> ggi                   libggi-2-0-0.dll      libggimisc.a          libgii.a
> libgg-0-0-6.dll       libggi.a              libggimisc.la
> libgg-0-0-7.dll       libggi.la             libgii-0-0-6.dll
> libgg.a               libggimisc-2-0-0.dll  libgii-0-0-7.dll

More information about the Cygwin-xfree mailing list