need help with bash -c <command> with cygpath

Christopher Faylor
Wed Jan 9 01:04:00 GMT 2008

On Tue, Jan 08, 2008 at 11:59:32PM +0000, Jay wrote:
>When i run
>>cygpath -a '\\uncpath\mydrive$'
>Which is the expected behaivor.
>When i run
>>bash -i -c "cygpath -a '\\uncpath\mydrive$'"
>Which is not what i want.  I'm trying to pass in the unc path from windows, so
>it needs converted.
>Why do i get different results depending on how it is called? 

  * cygwin-talk: a mindless chatter list.  This list is intended to be
  funny but not terribly helpful.  Do not send technical questions about
  Cygwin here.  Use the main cygwin mailing list for serious Cygwin
  questions since responses to technical questions in this list are not
  guaranteed to be serious or definitive.  No profanity, no commercial
  posts, and minimal flaming, please.

To answer your *technical question* - it's because of the way the
backslash is handled within double quotes.

If this answer either confuses and astounds you then please use the
cygwin mailing list to ask further questions.

More information about the Cygwin-talk mailing list