thunk createDirectory and createFile calls
Robert Collins
rbcollins@cygwin.com
Fri Nov 14 09:41:00 GMT 2003
Ok, this is the thin edge of the wedge:
thunk CreateDirectory and CreateFile throughout the core.
All inline, so there should be no performance hit, but the coming
unicode changes will be able to be done in one place.
I considered redefining the CreateDirectory and CreateFile calls but
decided against it.
I'd like to commit these parts in, as they are
a) common to every approach to this problem I can think of.
b) safe.
Is that ok?
2003-11-11 Robert Collins <rbtcollins@hotmail.com>
Ron Parker <rdparker@butlermfg.com>
Rename CreateFile to cygwin_create_file throughout.
Rename CreateDirectory to cygwin_create_directory throughout.
* assert.cc: Ditto.
* dcrt0.cc: Ditto.
* dir.cc: Ditto.
* exceptions.cc: Ditto.
* fhandler.cc: Ditto.
* fhandler_console.cc: Ditto.
* fhandler_disk_file.cc: Ditto.
* fhandler_proc.cc: Ditto.
* fhandler_socket.cc: Ditto.
* fork.cc: Ditto.
* ntea.cc: Ditto.
* path.cc: Ditto.
* security.cc: Ditto.
* spawn.cc: Ditto.
* syscalls.cc: Ditto.
* times.cc: Ditto.
* uinfo.cc: Ditto.
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: thunk-file-dir-opens.diff.changelog
URL: <http://cygwin.com/pipermail/cygwin-patches/attachments/20031114/cfe463a5/attachment.ksh>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: thunk-CreateFile-CreateDir.diff
URL: <http://cygwin.com/pipermail/cygwin-patches/attachments/20031114/cfe463a5/attachment-0001.ksh>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: io.h
URL: <http://cygwin.com/pipermail/cygwin-patches/attachments/20031114/cfe463a5/attachment.h>
More information about the Cygwin-patches
mailing list