cygwin does not compile

Dave Korn
Wed Oct 14 13:18:00 GMT 2009

Thomas Wolff wrote:
> Thanks. So I downloaded and called, but gcc -v
> still reports gcc 3.
> I could workaround this by putting /etc/alternatives in front of my
> PATH, but I don't think I'm supposed to have to do this (not documented
> anywhere, and manual pages are there, too).

  No, absolutely not, something must have gone wrong.  Could you try running
these commands and showing us the output (might be best to fork a separate
thread on the main list for this?):

/usr/sbin/update-alternatives --display gcc
/usr/sbin/update-alternatives --display g++
/usr/sbin/alternatives --set gcc /usr/bin/gcc-4.exe
/usr/sbin/update-alternatives --display gcc
for x in gcc g++ gcj gnat ; do
  /usr/sbin/alternatives --set $x /usr/bin/$x-4.exe
/usr/sbin/update-alternatives --display g++

> Now I ran a "make distclean" which gave me this error:
> Doing distclean in i686-pc-cygwin/winsup
> make[2]: Entering directory
> `/usr/src/cygwin-1.7.0-62/i686-pc-cygwin/winsup'
> make[2]: *** No rule to make target `distclean'.  Stop.
> make[2]: Leaving directory `/usr/src/cygwin-1.7.0-62/i686-pc-cygwin/winsup'
> make[1]: *** [distclean-target-winsup] Error 1
> make[1]: Leaving directory `/usr/src/cygwin-1.7.0-62'
> make: *** [do-distclean] Error 2
> Then, after a "make clean", I tried to configure and make again but it
> still fails with:

  Oh dear.  Looks like "make distclean" removed a generated file that isn't
being rebuilt.  I don't ever bother trying to recover a previously-built-in
directory to a pristine state myself; I'd suggest you throw it away and
re-install the source package.


More information about the Cygwin-developers mailing list