More: [1.7] packaging problem? Both /usr/bin/ and /usr/lib/ are non-empty

Christopher Faylor
Wed May 13 16:34:00 GMT 2009

On Wed, May 13, 2009 at 12:30:33PM +0000, Earnie Boyd wrote:
> Quoting Corinna Vinschen <>:
>>> Also, since mount already has a force entry maybe this option should
>>> be called "override" instead.  And, I agree with Eric that calling this
>>> "read-only" is confusing.  It doesn't mean what you'd expect if you have
>>> an idea of a similar option from linux.
>> Yes, I had already changed that locally.  Really, I have no strong
>> opinion for the exact words.  I would just like to have this sorted out
>> the way we discussed it.
> The string I use is 'noumount'.  Read-only is definitely what you intend to 
> mean.

We already have a "noumount" which is used for cygdrive mounts.  I guess
we could add that for /usr/lib, /usr/bin, and /, too.  I like "auto"
better but not enough to keep an argument going.  "noumount" isn't
exactly right to exactly denote what's going on with "/", though, IMO.  I
think you need another flag to set it apart from /usr/bin and /usr/lib.


More information about the Cygwin-developers mailing list