About "messed up user permissions from w2k terminal session"

Pierre A. Humblet Pierre.Humblet@ieee.org
Tue Oct 7 18:17:00 GMT 2003

Corinna Vinschen wrote:
> That would mean, any Cygwin process running under a non-priv'd account in
> a terminal server session will fail beginning with 2003 :-(  Blerch.
> > Is that privilege given routinely by MS?
> It's set to "undefined" in the domain and domain controller security
> policy dialogs.  I can't easily test if users have this right by default,
> at least not today.
> > I will check if this privilege might be related to the reported problem.
> AFAICS, SeCreateGlobalPrivilege doesn't exist prior to 03.  No hint for
> it's existance on my XP box.  Note that the report is talking about TS
> on 2K.  It shouldn't be a problem on 2K and XP.

Case solved, and we have a problem. 
This is what James Below tells me:

>>- Are you running on Windows 2000 or 2003?
> windows 2000 sp4

> I get the same error with 1.5.3
So it's a Cygwin 1.5 issue with using the global name space,
not related to my recent changes.

>here are the output files. 
showing the privileges, and only the admin user who can start Cygwin has:


So MS is not telling the full truth, windows 2000 sp4 is using the privilege.

So we have a few choices:
1) Roll back to using the local name space, which makes interprocess comm
   very difficult, or
2) Require the privilege to run Cygwin from Terminal Services,
3) Use the global name space only if the user has the privilege or
   we are not not running from TS.


More information about the Cygwin-developers mailing list