has anyone run the test suite recently?

Conrad Scott Conrad.Scott@dsl.pipex.com
Sat May 25 05:54:00 GMT 2002


"egor duda" <deo@logos-m.ru> wrote:
> Actually, testsuite is supposed to test not yet installed
> new-cygwin1.dll.
> If you take a look at Makefiles and testsuite scripts, you'll see that
> all tests are linked with special import library, which makes them use
> new-cygwin1.dll instead of cygwin1.dll and are run via cygrun so they
> don't interfere with other running cygwin processes.

Egor, there seems to be something amiss with this scheme then, since (as
Norman Vine also mentioned) "make check" fails some tests if the current
1.3.10-1 cygwin1.dll is installed, while it passes all the tests if the
newly built cygwin1.dll is installed instead. (This is with CVS HEAD as of
12 hours ago.)

I'm attaching the obj/i686-ps-cygwin/testsuite/testsuite/winsup.log from
such a failing run. Here's the (relevant) differences in that file from a
failing to a successful run:

--- obj-precheck/i686-pc-cygwin/winsup/testsuite/testsuite/winsup.log
2002-05-25 12:25:55.000000000 +0100
+++ obj/i686-pc-cygwin/winsup/testsuite/testsuite/winsup.log 2002-05-25
12:39:44.000000000 +0100
@@ -53,14 +53,10 @@
 XFAIL: ltp/dup05.c (execute)
 PASS: ltp/execl01.c
 PASS: ltp/execle01.c
-ltp/execlp01.c: child process exited abnormally
-FAIL: ltp/execlp01.c (execute)
-ltp/execv01.c: child process exited abnormally
-FAIL: ltp/execv01.c (execute)
-ltp/execve01.c: child process exited abnormally
-FAIL: ltp/execve01.c (execute)
-ltp/execvp01.c: child process exited abnormally
-FAIL: ltp/execvp01.c (execute)
+PASS: ltp/execlp01.c
+PASS: ltp/execv01.c
+PASS: ltp/execve01.c
+PASS: ltp/execvp01.c
 PASS: ltp/exit01.c
 PASS: ltp/exit02.c
 PASS: ltp/fchdir01.c


Note that on the failing run, I also get several dialogue boxes popping up
with the usual windows "foo.exe has generated errors and will be closed by
windows" etc. Of these, the first was for sh.exe, which happens before the
four failures shown above, and for that I also got a (rather empty)
sh.exe.stackdump:

Exception: STATUS_ACCESS_VIOLATION at eip=00000000
eax=00000000 ebx=00000000 ecx=615F0434 edx=610AC4E8 esi=615F00D8
edi=610AFE48
ebp=0022FEC0 esp=0022FE94 program=C:\cygwin\bin\sh.exe
cs=001B ds=0023 es=0023 fs=003B gs=0000 ss=0023
Stack trace:
Frame     Function  Args
End of stack trace

Then there were four dialogues popped up, each for test.exe, at the point at
which the four failures occurred. I got no stackdumps for these.

There's too much in this that I don't know anything about, so I'm not going
to investigate this (at least, not for a while) but I thought I'd post this
to make a record of the issue. Hope it helps at some point.

// Conrad
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: winsup.log
URL: <http://cygwin.com/pipermail/cygwin-developers/attachments/20020525/3f9392c0/attachment.log>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cygcheck.out
Type: application/octet-stream
Size: 19555 bytes
Desc: not available
URL: <http://cygwin.com/pipermail/cygwin-developers/attachments/20020525/3f9392c0/attachment.obj>


More information about the Cygwin-developers mailing list