Charles Wilson cwilson@ece.gatech.edu
Wed Oct 31 12:27:00 GMT 2001

Christopher Faylor wrote:

> Ok, the theory is that the execvp bug has been fixed, the ftpd bug has
> been fixed, the rsync "Dr. Watson" has been fixed.
> Can everyone try the latest snapshot/cvs and report any problems here?

Latest cvs cygwin1.dll seems to "work okay" -- I didn't do anything 
special, or run any kind of torture test.  I just built, installed, and 
used it -- I'm still using it for "normal" stuff without problems.  (I 
realize this may not be exactly the kind of report you were looking for, 
but it IS a data point, and is IS good news. Hopefully that is welcome 
enough).  The next part is not so good.

setup.exe (2.112):  The current vs. new vs. prev vs. test detection 
algorithm doesn't seem to work properly.  (e.g. parsing 
/etc/setup/installed.db and/or setup.ini)

Setup.ini says

@ ash
sdesc: "A Bourne Shell (/bin/sh) workalike"
category: Base Shells
requires: cygwin
version: 20011018-1
install: latest/ash/ash-20011018-1.tar.bz2 33819
source: latest/ash/ash-20011018-1-src.tar.bz2 143186
version: 20010827-1
install: latest/ash/ash-20010827-1.tar.bz2 33780
source: latest/ash/ash-20010827-1-src.tar.bz2 143017

When my current installation was 20010827-1 (according to 
/etc/setup/installed.db) the latest setup was perfectly happy (that is, it 
did not want to update ash).  It just said:
20010827-1  Keep

choosing 'Prev' or 'Curr' or 'Exp' had no effect.  Still '20010827-1 Keep'. 
  Changing the 'View' to Full had no effect, while changing the View to 
Partial merely removed ash from the list (e.g. setup was happy with my 
20010827-1 version).

So, I clicked on the 'Keep' until it changed to '20011018-1'  -- which had 
the unfortunate side effect of reverting my "skipped" cygwin package to 
'I'm gonna install 1.3.3-2' (I had previously used setup to install my 
custom cygwin-20011031 snapshot, and I wanted to stick with it for a 
while).  So I had to go click THAT to change it back to 'skip'

That "skippage" had no effect.  It still tried to "update" the cygwin 
package to 1.3.3-2.  Bleagh.  (Also, since I had a bash window open, the 
cygwin1.dll was in use so the update of the cygwin package failed 
disastrously --  first it popped up a MessageBox that said "cygwin1.dll in 
use".  I clicked OK.  Then it bluescreened my W2K box and autorebooted. 
Not good.  However, I do not think this BSODage is a real problem with 
*setup* -- my machine has been unstable of late)

Anyway, after rebooting, I tried again (without any active cygwin windows). 
  I let it do its thing (e.g install new ash, but let it also "update" 
cygwin).  I then reinstalled my custom cygwin snapshot.

Finally, I ran setup AGAIN -- just to see what it would say about my "new" 

Again, it's happy. '20011018-1 Keep'

It appears that setup is perfectly happy with WHATEVER version of a given 
pacakge is already installed.  The whole [test], [prev] and current thing 
seems to be ignored.

Where would I look within setup's code to track this evilness down?  (BTW, 
at the risk of pulling a McNulty, I have to rebuild my firewall/router 
today so I'll be offline for a while, and may not react to any forthcoming 
advice until tomorrow)


More information about the Cygwin-developers mailing list