What is dtable

Earnie Boyd earnie_boyd@yahoo.com
Mon May 14 13:39:00 GMT 2001


Brian Keener wrote:
> 
> Earnie Boyd wrote:
> > Ok.  So did *YOU* do the `make clean' from /usr/develop/obj or are you
> 
> *I* did the make clean in /usr/develop/obj/i686-pc-cygwin/winsup/cygwin
> after I realized something was wrong per Chris' response.
> 
> > assuming the `make clean' in the script above did the clean?  If the
> 
> *I* was assuming the script would perform the 'make clean' which I
> thought was the purpose of the script to keep me from having to remember
> all the things to type.
> 
> > latter the script is only executing the clean in the
> > i686-pc-cygwin/winsup/cinstall directory
> 
> *I* don't see this in the script - as the cd to
> i686-pc-cygwin/winsup/cinstall is a comment (unless # character is no
> longer a comment) would this not mean that the previous cd to
> /usr/develop/obj would be the last one to occur and thus the script would
> be running the 'make clean' in that directory.
> 

Hmm...  I missed that.

> > Which is not in the top build
> > directory!
> 
> The top directory is /usr/develop/obj which was the last place cd'd to
> before the make clean.
> 
> > If the former I don't understand why it would work for me
> > and not you.
> 
> *I* don't either, obviously - maybe it's the evil Win95 vs WinNt thing
> again.  I can only assume my script does not type so well and in the
> future *I* must type the 'make clean' myself from the appropriate
> directory instead of relying on a script to perform that action for me.
> 

You could try it now I suppose.  It should work from either.

> If I upset you by insinuating that make would not do recursion - my
> apologies.  I obviously made an incorrect assumption and once again shot
> my mouth off.  One of these days I hope to learn to engage my brain
> before engaging my mouth.

I'm not upset just perplexed and trying to figure out the scenario.  If
it isn't working something's broke somewhere.

Wait, you're doing a configure prior to the make clean.  That could be
the problem since the initial Cygwin makefile is a special make run that
establishes the makefiles for the subdirectories.  You should try moving
the `make clean' before the configure and see if that helps.

-- 
Earnie.

_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com




More information about the Cygwin-developers mailing list