Fix for ssh problems

Matt matt@use.net
Thu May 10 23:24:00 GMT 2001


On Fri, 4 May 2001, Christopher Faylor wrote:

> Corinna reported a problem with sshd and debugged it enough that I
> could (eventually) figure out what I think was happening.  I just
> checked in a fix for the problem, I hope.
>
> I don't know if this will fix Matt's ssh problems or not, but please
> give the current CVS Cygwin a try.

I just tried the 20010508 snapshot, which doesn't fix th problem on win9x.
(The problem being that after scp'ing a file, an ssh process hangs
around.)

As suggested before, I updated my gdb (to 20010428-1) and attempted to
attach to the ssh process. I got the same results as before: gdb misprints
the pid as a negative number, then uses 85% of the CPU. When I try to kill
gdb by closing the window, my machine becomes unresponsive (no capslock
or ctrl+alt+del reponse) for awhile, and
I've found it easier to reboot than wait for it to come back.

Not sure what to do from here. Suggestions? Can someone else try attaching
to the process on win9x and seeing if gdb has the same result?


--
http://www.clock.org/~matt



More information about the Cygwin-developers mailing list