Outstanding issues with current DLL?

Christopher Faylor cgf@redhat.com
Sat Mar 10 15:45:00 GMT 2001


On Thu, Mar 08, 2001 at 02:41:14PM -0500, Earnie Boyd wrote:
>Christopher Faylor wrote:
>> 
>> On Thu, Mar 08, 2001 at 01:17:30PM -0500, Earnie Boyd wrote:
>> >Christopher Faylor wrote:
>> >>I could use a little more detail, however, like when this started
>> >>failing.  It sounds like this could be related to Egor's changes to pty
>> >>handling or, if this is very recent, to my signal handling changes.
>> >>
>> >
>> >Sometime between 2/28 and 3/06, IIRC.  I could have been using a 2/23
>> >prior to the 3/06 update though.  I really haven't had spare cycles for
>> >tracking down problems recently.  Wish I could help find this problem.
>> >It is definitely a race condition.  I just had one happen and started
>> >another process while the other was hung just fine.
>> 
>> Can you detail the series of events that led to the hang?  Were you typing
>> anything?  Or did it just hang immediately on starting bash via rxvt?
>> 
>> I don't use rxvt routinely but it sounds like I should be able to duplicate
>> this.
>> 
>
>The hang happens after clicking on the icon on the desktop.  I've always
>awaited for a bash prompt that never returns.  The first time it
>happened was right after I installed after building on 3/06.  It
>mysteriously went away and I've had it happen occasionally ever since.

Ok.  I just tried about 40 times to duplicate this and was unable to do
so.  Could you send a cygcheck -r -s -v?

Also, just on a hunch, could you try typing commands in the rxvt window
and see if anything displays?  I've just had something similar to this
happen to me.  bash appeared to be hung but it was actually not recognizing
that it was running in a cygwin tty so it didn't display any prompt.

cgf



More information about the Cygwin-developers mailing list