[RFC] Is that error mapping correct?

Corinna Vinschen corinna@vinschen.de
Tue May 2 17:45:00 GMT 2000

Chris Faylor wrote:
> On Tue, May 02, 2000 at 07:17:21PM -0400, DJ Delorie wrote:
> >> >    $ cat //foo/bar/baz
> >> >    cat: //foo/bar/baz: No such device or address
> >> >
> >> >seems somewhat strange. Have I missed something, perhaps?
> >>
> >> I don't know.  Is there some UNIX equivalent that we could use for
> >> testing?  It is nice to differentiate between a non-existent file and a
> >> non-existent host but I agree that the current error doesn't make much
> >> sense.
> >
> >I unplugged my SGI's ethernet cable and tried to access a file on it
> >from Linux (via nfs) and got EIO - "Input/output error".  I'm not sure
> >if this is the same situation, though.
> I tried to do a "rcp foweroqwer:/tmp/foo ." and got a "Host not found"
> but that doesn't seem to be an errno.

I think you won't found something similar in UNIX. Neither
Samba allows usage of that type of path nor NFS. You always
have to mount. The "r" protocol family on the other hand isn't
transparently usable. So I would plead for the Win users point
of view: It's a file or directory path, nothing else.


More information about the Cygwin-developers mailing list