calm warnings for libgfortran5 & libgnat8

Jon Turney jon.turney@dronecode.org.uk
Fri Apr 12 16:10:00 GMT 2019


On 12/04/2019 15:26, Andrew Schulman wrote:
> calm sent me the below after I uploaded screen-4.6.2-3. Do I need to do
> anything about the warnings? I'm not sure what they're about. I don't think
> I have any packages that depend on libgfortran5 or libgnat8, but maybe I'm
> wrong.

It's safe for you to ignore these messages.

These are warnings about the current state of the package release area 
after the test release gcc 8.3.0-1 was uploaded (in which libfortan and 
libgnat had soversion bumps, so now exist as packages without a current 
version)

Unfortunately calm is not (currently) smart enough to know who needs to 
be told about this, so it tells everyone.

Since the situation is intended, I've configured the appropriate 
suppressions for these warnings to shut calm up.

Sorry for any confusion caused.

> WARNING: package 'libgfortran5' doesn't have a curr version
> WARNING: package 'libgfortran5' doesn't have a curr version
> WARNING: package 'libgnat8' doesn't have a curr version
> WARNING: package 'libgfortran5' doesn't have a curr version
> WARNING: package 'libgfortran5' doesn't have a curr version
> WARNING: package 'libgnat8' doesn't have a curr version



More information about the Cygwin-apps mailing list