mbed TLS package

Jon Turney jon.turney@dronecode.org.uk
Sat Apr 29 11:33:00 GMT 2017

On 29/04/2017 12:10, Andy Li wrote:
> I've just tried to upload the package, and calm notified me about the
> errors as follows:
>> ERROR: package 'libmbedtls10' version '2.4.2-1' requires nonexistent package 'libmbedx509'
>> ERROR: package 'mbedtls-devel' version '2.4.2-1' requires nonexistent package 'libmbedx509'
>> ERROR: error while validating merged x86 packages for Andy Li
> Maybe it's because of "libmbedx509" having a number at the end of its
> name, incorrectly interpreted as its version number (0)?
> Its package name is "libmbedx509-0".

Using a package name containing a hyphen followed by a digit isn't 
actually forbidden currently, but perhaps should be.  It introduces an 
ambiguity about where the version starts.

This seems to tickle a bug somewhere in cygport as it doesn't generate 
the requires: correctly

It would be much better if cygport just said "no" when you tried to use 
a package name with a hyphen followed by a digit.

> Any tips to fix it is appreciated.

Name the package 'libmbedx509_0'

See [1], which we generally follow:

"If the base package name ends with a digit, a single underscore ("_") 
MUST be appended to the name, and the version MUST be appended to that, 
in order to avoid confusion over where the name ends and the version 


More information about the Cygwin-apps mailing list