Ping/offer on FlexDLL 0.35, OCaml 4.04, Camlp4, etc.

Yaakov Selkowitz yselkowitz@cygwin.com
Thu Nov 24 20:34:00 GMT 2016


On 2016-11-24 14:06, Anton Bachin wrote:
> Cygwin’s package “ocaml” is currently at 4.02.3, and “flexdll” is at
> 0.34. The latest FlexDLL, 0.35, makes it possible to build and use OCaml
> 4.03.0 and 4.04.0 on Cygwin [1].

Thanks for the ping, I just uploaded 0.35.  Hopefully that, combined 
with a new ocaml build, will fix the issues I was having rebuilding my 
various ocaml libs for 4.02.3.

> I am not sure who is the current maintainer of these packages. I
> searched the mailing list, and found Damien Doligez apparently submitted
> OCaml 4.01.0.

And 4.02.3.

> However, I package releases of OCaml and related packages in little
> Cygwin mirrors, for use on build bots [2]. If desired, I can adapt the
> packages to be suitable for public Cygwin, and submit them. I expect to
> be making the build bot packages for quite a while, so I should be able
> to also submit to Cygwin on an ongoing basis.

Damian, your thoughts?

-- 
Yaakov



More information about the Cygwin-apps mailing list