lftp 4.7.4 build fails with bad gettext version

Andrew Schulman schulman.andrew@epa.gov
Wed Nov 23 23:39:00 GMT 2016


> On 11/16/2016 1:36 PM, Andrew Schulman wrote:
> > Using cygport with no custom src_build function and
> > CYGCONF_ARGS="--with-openssl --enable-packager-mode", the build fails with
> > a mysterious message about a mismatched gettext version:
> >
> > ASchulma@LZ77E1AASCHULMA ~/d/c/lftp> cygport lftp.cygport build
> >>>> Compiling lftp-4.7.4-1.x86_64
> > autoreconf-2.69: Entering directory `.'
> > autoreconf-2.69: running: /usr/bin/autopoint -V 0.19.8.1 --force
> > autopoint: warning: Version mismatch: specified -V 0.19.8.1 but the package
> > uses gettext version 0.15. Forcibly upgrading to 0.19.8.1
> > autopoint: *** The AM_GNU_GETTEXT_VERSION declaration in your configure.ac
> >                file requires the infrastructure from gettext-0.19.8.1 but
> > this version
> >                is older. Please upgrade to gettext-0.19.8.1 or newer.
> > autopoint: *** Stop.
> > autoreconf-2.69: /usr/bin/autopoint failed with exit status: 1
> > *** ERROR: autoreconf failed
> >
> > So it says it wants gettext 0.19.8.1, but "the package uses gettext version
> > 0.15".  But I have gettext 0.19.8.1 installed:
> 
> This seems to be fixed in the latest cygport.

Yes, it is. Thanks.
Andrew



More information about the Cygwin-apps mailing list