lftp 4.7.4 build fails with bad gettext version

Andrew Schulman schulman.andrew@epa.gov
Wed Nov 16 18:37:00 GMT 2016

Using cygport with no custom src_build function and
CYGCONF_ARGS="--with-openssl --enable-packager-mode", the build fails with
a mysterious message about a mismatched gettext version:

ASchulma@LZ77E1AASCHULMA ~/d/c/lftp> cygport lftp.cygport build
>>> Compiling lftp-4.7.4-1.x86_64
autoreconf-2.69: Entering directory `.'
autoreconf-2.69: running: /usr/bin/autopoint -V --force
autopoint: warning: Version mismatch: specified -V but the package
uses gettext version 0.15. Forcibly upgrading to
autopoint: *** The AM_GNU_GETTEXT_VERSION declaration in your configure.ac
               file requires the infrastructure from gettext- but
this version
               is older. Please upgrade to gettext- or newer.
autopoint: *** Stop.
autoreconf-2.69: /usr/bin/autopoint failed with exit status: 1
*** ERROR: autoreconf failed

So it says it wants gettext, but "the package uses gettext version
0.15".  But I have gettext installed:

ASchulma@LZ77E1AASCHULMA ~/d/c/lftp> cygcheck -c gettext
Cygwin Package Information
Package              Version        Status
gettext         OK

Does anyone know what the problem is here?  

The last time I built lftp 4.7.3 it worked fine, but now the build of that
fails too, with the same error as above. So this seems to be caused by
autoconf, gettext, or something else in the Cygwin build environment,
rather than by lftp.


More information about the Cygwin-apps mailing list