unison-2.48 build fails with latest ocaml and flexdll (ping: Yaakov, Damien)

Marco Atzeri marco.atzeri@gmail.com
Thu Apr 28 08:03:00 GMT 2016

On 26/04/2016 21:47, Andrew Schulman wrote:
>> I'm trying to build unison 2.48.3, which worked fine the last time I tried
>> it, in June 2015.  Today the build fails, with "flexdll error: cannot
>> relocate":
>>>>> Compiling unison2.48-2.48.3-2.x86_64
>> ocamlc -o mkProjectInfo unix.cma str.cma mkProjectInfo.ml
>> File "mkProjectInfo.ml", line 1:
>> Error: Error on dynamically loaded library:
>> /usr/lib/ocaml/stublibs/dllunix.so: flexdll error: cannot relocate
>> RELOC_REL32, target is too far: 0xfffffffc0f997112  0xf997112
>> I ran /bin/rebaseall and tried again, with the same result.
> This is still unresolved. I can't build unison-2.48.3 on any of my Cygwin
> hosts. It worked a year ago; now it doesn't. Can you help?
> Thanks,
> Andrew

There was an issue rebasing that file some time ago.


I suggest at least to try a full rebase with
  /usr/bin/rebase-trigger full
and re-running setup.
I don't remember if rebaseall is rebasing from scratch or not.


More information about the Cygwin-apps mailing list