unison-2.48 build fails with latest ocaml and flexdll (ping: Yaakov, Damien)

Andrew Schulman schulman.andrew@epa.gov
Wed Apr 27 09:16:00 GMT 2016

> Andrew Schulman writes:
> >> I'm trying to build unison 2.48.3, which worked fine the last time I tried
> >> it, in June 2015.  Today the build fails, with "flexdll error: cannot
> >> relocate":
> >> 
> >> >>> Compiling unison2.48-2.48.3-2.x86_64
> >> ocamlc -o mkProjectInfo unix.cma str.cma mkProjectInfo.ml
> >> File "mkProjectInfo.ml", line 1:
> >> Error: Error on dynamically loaded library:
> >> /usr/lib/ocaml/stublibs/dllunix.so: flexdll error: cannot relocate
> >> RELOC_REL32, target is too far: 0xfffffffc0f997112  0xf997112
> >> 
> >> I ran /bin/rebaseall and tried again, with the same result.
> >
> > This is still unresolved. I can't build unison-2.48.3 on any of my Cygwin
> > hosts. It worked a year ago; now it doesn't. Can you help? 
> Well, check where the library you've just compiled has been based to.
> You can change the image-base of the compiles, see:
> https://www.cygwin.com/ml/cygwin-apps/2013-05/msg00096.html

Thanks, but nothing has been been compiled yet; the build fails immediately. 

I'm not sure if you meant that as diagnosis or solution. It doesn't seem like a
solution.  Changing the image base of my compiles seems like an extraordinary
measure.  Unison has always built just fine OOTB before.


More information about the Cygwin-apps mailing list