unison-2.48 build fails with latest ocaml and flexdll (ping: Yaakov, Damien)

Achim Gratz Stromeko@nexgo.de
Tue Apr 26 20:16:00 GMT 2016

Andrew Schulman writes:
>> I'm trying to build unison 2.48.3, which worked fine the last time I tried
>> it, in June 2015.  Today the build fails, with "flexdll error: cannot
>> relocate":
>> >>> Compiling unison2.48-2.48.3-2.x86_64
>> ocamlc -o mkProjectInfo unix.cma str.cma mkProjectInfo.ml
>> File "mkProjectInfo.ml", line 1:
>> Error: Error on dynamically loaded library:
>> /usr/lib/ocaml/stublibs/dllunix.so: flexdll error: cannot relocate
>> RELOC_REL32, target is too far: 0xfffffffc0f997112  0xf997112
>> I ran /bin/rebaseall and tried again, with the same result.
> This is still unresolved. I can't build unison-2.48.3 on any of my Cygwin
> hosts. It worked a year ago; now it doesn't. Can you help? 

Well, check where the library you've just compiled has been based to.
You can change the image-base of the compiles, see:


+<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+

Factory and User Sound Singles for Waldorf rackAttack:

More information about the Cygwin-apps mailing list