ITA: gcc-mingw-* gcc-3 -mno-cygwin support packages; ITP: mingw-binutils/mingw-gcc-* cross compiler

Charles Wilson
Mon Jan 24 16:55:00 GMT 2011

On 1/23/2011 11:36 PM, Yaakov (Cygwin/X) wrote:
> On Tue, 2010-11-23 at 17:28 -0500, Charles Wilson wrote:
>> Updated packages are available by pointing setup.exe here:
> Could you sign your setup.ini and post the GPG key (for setup -K)?

Err...not reliably.  I'm still confused about GPG and its relationship
with multiple email aliases.  I don't really WANT <s>people</s>
automated bots connecting my various aliases together via a shared
keyring, but that appears to be the only way to easily use GPG with
multiple aliases.  The alternative is to use completely separate
keyrings...which is a huge pain.  So...I've never really bothered to
"get into" the whole GPG thing (*), which means that any key I have is
not hooked into any web-of-trust.  So, I could sign it, and post a
public key...but could anybody REALLY trust it?

(*) About 18 months ago, I tried to sort all this out along with porting
gnupg2 and its prereqs -- and eventually ITP'ed all but gnupg2 itself.
However, I ran into a couple of roadblocks and tabled any further
progress pending...

"Passing file descriptors over a socket"

"GNU pth + cygwin + fork [Was: Re: fork failure?]"
(cgf: "Let me add a new data point: I'll implement sigaltstack after
1.7.1 is released." -- )

Also, I had a long message summarizing all these travails, and talking
about the (then-)current state of my gnupg2 port, and asking for advice
as to whether I should ITP it in its not-completely-working state
(gpg-agent no-workee, but everything else seemed to). I never got a
response, so...I tabled everything.

I now know why I never got a response.  I misaddressed the message, but
never noticed because I got my Bcc:!  I'll revisit in another, more
appropriate thread.

>> = mingw-zlib-1.2.5-4-src.tar.bz2
>> = mingw-zlib-1.2.5-4.tar.bz2
>> = mingw-zlib-devel-1.2.5-4.tar.bz2
>> = mingw-zlib1-1.2.5-4.tar.bz2
> The sharedlibdir variable in zlib.pc needs to be fixed.



$ ls /usr/i686-pc-mingw32/sys-root/mingw/bin/libbz*

I thought the installed files were NOT going to reflect paths on the
actual $host, but instead were going to reflect the paths on $build,
with the possible exception of those areas where specialized sysroot
support with the special '=' character ('=/mingw/foo') was available?

Are you suggesting that the $sharedlibdir variable in .pc files is an
appropriate place for '=' substitution?


More information about the Cygwin-apps mailing list