[cygwin-apps htdocs - The cygwin-apps website files] branch master, updated. 06bff80dacb297b9acdef2676425359027381347

jturney@sourceware.org jturney@sourceware.org
Fri Jul 6 13:56:00 GMT 2018




https://sourceware.org/git/gitweb.cgi?p=cygwin-apps/apps-htdocs.git;h=06bff80dacb297b9acdef2676425359027381347

commit 06bff80dacb297b9acdef2676425359027381347
Author: Jon Turney <jon.turney@dronecode.org.uk>
Date:   Mon Jan 29 18:29:32 2018 +0000

    Document setup-minimum-version:


Diff:
---
 setup.ini.html |   14 +++++++++-----
 1 files changed, 9 insertions(+), 5 deletions(-)

diff --git a/setup.ini.html b/setup.ini.html
index 1b89b0b..dba6f60 100644
--- a/setup.ini.html
+++ b/setup.ini.html
@@ -50,11 +50,15 @@ regression.</p>
 
 <p><tt>setup-version: <i>version</i></tt></p>
 <p>
-The version of setup for which this <tt>setup.ini</tt> was generated. Setup will
-warn if the version of setup is less than the version in a <tt>setup.ini</tt>
-file. In the future this may get decoupled from the <tt>setup.ini</tt> version,
-and be coupled to the parser logic, to allow older versions of setup that can
-operate correctly on a <tt>setup.ini</tt> file to do so without warnings.</p>
+The current version of setup when this <tt>setup.ini</tt> was generated.  Setup
+will warn if the version of setup is less than this version.
+</p>
+
+<p><tt>setup-minimum-version: <i>version</i></tt></p>
+<p>
+The minimum version of setup needed to correctly parse and process
+this <tt>setup.ini</tt>.  Setup won't proceed if it's version is less than this.
+</p>
 
 <p><tt>release: text</tt><p>
 <p>A label for the package set.  The label <tt>cygwin</tt> is reserved for use



More information about the Cygwin-apps-cvs mailing list