[setup - the official Cygwin setup program used to install Cygwin and keep it up to date] branch master, updated. release_2.875-9-ge75d09f

jturney@sourceware.org jturney@sourceware.org
Fri Sep 2 08:47:00 GMT 2016




https://sourceware.org/git/gitweb.cgi?p=cygwin-apps/setup.git;h=e75d09f1cd2e1f3742bae648d48220901e2fb7b4

commit e75d09f1cd2e1f3742bae648d48220901e2fb7b4
Author: Jon Turney <jon.turney@dronecode.org.uk>
Date:   Thu Sep 1 20:30:44 2016 +0100

    Refuse to run on Windows XP and earlier
    
    Refuse to run on Windows versions less than 6.0 (XP or previous), as they
    are no longer supported by Cygwin.
    
    Future work: The version checked against should be read from setup.ini,
    rather than hard-coded here, so that this version of setup cannot be used to
    download a future version of Cygwin which isn't compatible with the Windows
    version it's running on...
    
    Signed-off-by: Jon Turney <jon.turney@dronecode.org.uk>


Diff:
---
 main.cc |    8 ++++++++
 1 files changed, 8 insertions(+), 0 deletions(-)

diff --git a/main.cc b/main.cc
index 3d6e6fb..f08da00 100644
--- a/main.cc
+++ b/main.cc
@@ -290,6 +290,14 @@ WinMain (HINSTANCE h,
 			<< setup_version << endLog;
       }
 
+    /* Check if Cygwin works on this Windows version */
+    if (OSMajorVersion () < 6)
+      {
+        mbox (NULL, "Cygwin is not supported on this Windows version",
+              "Cygwin Setup", MB_ICONEXCLAMATION | MB_OK);
+        exit (1);
+      }
+
     if (help_option)
       {
 	if (invalid_option)



More information about the Cygwin-apps-cvs mailing list